Senin, 25 April 2011
11.54 |
Diposting oleh
Muhammad Rezky Pratama |
Edit Entri
Tunneling itu apa sih ? Tunneling adalah teknik mengenkapsulasi seluruh paket data dari format
protokol yang lain. Dengan kata lain, paket data asli akan ditambahkan
header dari tunneling protokol tersebut. Hasil enkapsulasi tersebut
kemudian akan dikirim melalui infrastruktur jaringan menuju node tujuan.
Kali ini saya mencoba membuat simulasi tunneling secara manual. Topologi perencanaan manual tunneling ini :
Yang dibutuhkan untuk implementasi:
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
ipv6 address FEC0::2:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
no ip address
ipv6 address FEC0::5:1/112
ipv6 ospf 2 area 0
tunnel source FastEthernet0/0
tunnel destination 192.168.2.1
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
speed auto
full-duplex
!
interface FastEthernet0/1
no ip address
speed auto
full-duplex
ipv6 address FEC0::1:1/112
ipv6 ospf 2 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ipv6 router ospf 2
log-adjacency-changes
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Konfigurasi R2
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 192.168.2.2 255.255.255.0
speed auto
full-duplex
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp run
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end
Konfigurasi R3
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
ipv6 address FEC0::3:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
no ip address
ipv6 address FEC0::5:2/112
ipv6 ospf 2 area 0
tunnel source FastEthernet0/0
tunnel destination 192.168.1.1
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
speed auto
full-duplex
!
interface FastEthernet0/1
no ip address
speed auto
full-duplex
ipv6 address FEC0::4:1/112
ipv6 ospf 2 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.3 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ipv6 router ospf 2
log-adjacency-changes
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Hasil Implementasi :
Kali ini saya mencoba membuat simulasi tunneling secara manual. Topologi perencanaan manual tunneling ini :
Topology |
- 1 buah Komputer/Laptop
- Software GNS3, dapat didownload disini
- IOS cisco c3725-adventerprisek9-mz.124-18.bin, dapat didownload disini
- Virtual PC, dapat didownload disini
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
ipv6 address FEC0::2:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
no ip address
ipv6 address FEC0::5:1/112
ipv6 ospf 2 area 0
tunnel source FastEthernet0/0
tunnel destination 192.168.2.1
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
speed auto
full-duplex
!
interface FastEthernet0/1
no ip address
speed auto
full-duplex
ipv6 address FEC0::1:1/112
ipv6 ospf 2 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ipv6 router ospf 2
log-adjacency-changes
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Konfigurasi R2
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 192.168.2.2 255.255.255.0
speed auto
full-duplex
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp run
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end
Konfigurasi R3
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
ipv6 address FEC0::3:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
no ip address
ipv6 address FEC0::5:2/112
ipv6 ospf 2 area 0
tunnel source FastEthernet0/0
tunnel destination 192.168.1.1
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
speed auto
full-duplex
!
interface FastEthernet0/1
no ip address
speed auto
full-duplex
ipv6 address FEC0::4:1/112
ipv6 ospf 2 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.3 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ipv6 router ospf 2
log-adjacency-changes
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Hasil Implementasi :
Tracert PC2->PC1 |
Test Ping R3 |
Interface Tunnel R3 |
Tracert dari PC1->PC2 |
Test Ping dari R1->PC2 |
Interface Tunnel di R1 |
Langganan:
Posting Komentar (Atom)
0 komentar:
Posting Komentar