Selasa, 26 April 2011
13.35 |
Diposting oleh
Muhammad Rezky Pratama |
Edit Entri
Berdasarkan definisi, GRE (Generic Routing Encapsulation) digunakan untuk enkapsulasi IP/non-IP menjadi IPv4/IPv6. Dalam simulasi kali ini, saya mencoba untuk membuat Tunneling GRE IPv6 over IPv4, yang berarti core network ialah IPv6 dan user network ialah IPv4.
Topologi yang akan saya gunakan sepert ini :
Yang dibutuhkan untuk implementasi:
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
ipv6 address FEC0::2:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
ip address 192.168.3.1 255.255.255.252
tunnel source FastEthernet0/0
tunnel destination FEC0::4:1
tunnel mode gre ipv6
!
interface FastEthernet0/0
no ip address
speed auto
full-duplex
ipv6 address FEC0::1:1/112
ipv6 ospf 2 area 0
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
speed auto
full-duplex
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.3 area 0
!
ipv6 router ospf 2
log-adjacency-changes
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Konfigurasi R2:
!
hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
speed auto
full-duplex
ipv6 address FEC0::1:2/112
ipv6 ospf 2 area 0
!
interface FastEthernet0/1
no ip address
speed auto
full-duplex
ipv6 address FEC0::4:2/112
ipv6 ospf 2 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ipv6 router ospf 2
log-adjacency-changes
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
Konfigurasi R3:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
ipv6 address FEC0::3:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
ip address 192.168.3.2 255.255.255.252
tunnel source FastEthernet0/0
tunnel destination FEC0::1:1
tunnel mode gre ipv6
!
interface FastEthernet0/0
no ip address
speed auto
full-duplex
ipv6 address FEC0::4:1/112
ipv6 ospf 2 area 0
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
speed auto
full-duplex
!
router ospf 1
log-adjacency-changes
network 10.10.10.3 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.3 area 0
!
ipv6 router ospf 2
log-adjacency-changes
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Hasil Implementasi :
Ilustrasi GRE tunneling IPv6 |
Topologi GRE Tunneling IPv6 over IPv4 |
- 1 buah Komputer/Laptop
- Software GNS3, dapat didownload disini
- IOS cisco c3725-adventerprisek9-mz.124-18.bin, dapat didownload disini
- Virtual PC, dapat didownload disini
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
ipv6 address FEC0::2:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
ip address 192.168.3.1 255.255.255.252
tunnel source FastEthernet0/0
tunnel destination FEC0::4:1
tunnel mode gre ipv6
!
interface FastEthernet0/0
no ip address
speed auto
full-duplex
ipv6 address FEC0::1:1/112
ipv6 ospf 2 area 0
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
speed auto
full-duplex
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.3 area 0
!
ipv6 router ospf 2
log-adjacency-changes
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Konfigurasi R2:
!
hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
speed auto
full-duplex
ipv6 address FEC0::1:2/112
ipv6 ospf 2 area 0
!
interface FastEthernet0/1
no ip address
speed auto
full-duplex
ipv6 address FEC0::4:2/112
ipv6 ospf 2 area 0
!
router ospf 1
log-adjacency-changes
network 10.10.10.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ipv6 router ospf 2
log-adjacency-changes
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
Konfigurasi R3:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
ipv6 address FEC0::3:1/112
ipv6 ospf 2 area 0
!
interface Tunnel1
ip address 192.168.3.2 255.255.255.252
tunnel source FastEthernet0/0
tunnel destination FEC0::1:1
tunnel mode gre ipv6
!
interface FastEthernet0/0
no ip address
speed auto
full-duplex
ipv6 address FEC0::4:1/112
ipv6 ospf 2 area 0
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
speed auto
full-duplex
!
router ospf 1
log-adjacency-changes
network 10.10.10.3 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.3 area 0
!
ipv6 router ospf 2
log-adjacency-changes
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Hasil Implementasi :
Capture Packet Wireshark |
Ping PC2->PC1 |
Debug Tunnel R1 |
Ping PC1->PC2 |
Langganan:
Posting Komentar (Atom)
0 komentar:
Posting Komentar